Do We Support Older Browsers?


I’m sure that most of you have heard about Kogan charging IE7 users extra ‘tax’, to support that old browser. My friend Eric wrote a good post on this. This stuck out to me (and made me laugh out loud).

I’m in the business of building applications, not supporting someone’s fetish for being stuck in a rut with old technology.

My contract very specifically states that I support the most current version of each browser, not every version, and that support for older versions may cost extra. Yes that means I don’t support IE7 by default unless the client requires it, then I build it in to the estimate.

I think what Kogan is doing is great. Sure use the older browser, but you’re going to pay extra for the time it takes to support older browsers. I can hear IT people cringing, as well they should be. Get of IE7 people.